DISAG-Wissenswertes und Tipps

  • Heute morgen ähnliches Phänomen... Netzwerkverbindung zum OpticScore-PC hat laut Icon funktioniert, Verbindung miniPC zum Messrahmen nicht. Ping vom Steuer-PC erreicht alle Maschinen.

    Als Test die SIZs stromlos geschaltet, wieder angeschaltet - Verbindung gefunden und funktional.

    Kann das irgendwas mit der Einschaltreihenfolge zu tun haben? Es könnte sein, dass der Switch noch stromlos war, als die SIZs hochgefahren wurden, aber versucht das SIZ dann nicht später erneut, den Messrahmen zu finden?

  • Netzwerk, Server, Clients. Diese Reihenfolge sollte man unabhängig vom jeweiligen System immer einhalten. Beim Ausschalten genau andersherum. Alles andere kann funktionieren. Aber darauf möchte man sich nicht verlassen.

    Wer will findet Wege. Wer nicht will findet Gründe.

  • Man braucht sich ja nur die Aufgaben der Komponenten ansehen:

    • Router: Verteilt IP-Adressen im Netzwerk (ggf. anhand von Reservierungen) und stellt eine Internetverbindung allen angeschlossenen Geräten zur Verfügung, benötigt zum Booten etwas Zeit, sollte daher als erstes gestartet werden oder auf Dauerstrom hängen
    • Switches: Verbinden alle Geräte mit Netzwerkanschluss untereinander. Switches sind i.d.R. sehr schnell, was den Bootvorgang angeht, können also gleichzeitig mit Netzwerkgeräten wie Netzwerkdrucker, etc. gestartet werden
    • AccessPoints: Ermöglichen WLAN-Geräten einen Zugang zum verkabelten Netzwerk, damit z. B. Tablets vom Router eine IP-Adresse beziehen können. Diese benötigen auch etwas Zeit zum Hochfahren und sollten logischerweise etwas vor den Geräten starten, die den AP benötigen; kann gleichzeitig mit den Switches gestartet werden; da AccessPoints selber auch eine IP-Adresse benötigen, müssen vorher Router und Switches laufen; meistens sind APs in WLAN Routern integriert, d.h. nur wenn tatsächlich zusätzliche AccessPoints (z.B. wegen räumlicher Trennung) vorhanden sind, spielen diese eine Rolle
    • Gate/Tablets: in der Tablet-Variante stellt das Gate alle Ressourcen für die Tablets zur Verfügung, d.h. es ist unbedingt notwendig. Es sollte erst nach den Switches gestartet werden, da das Gate selbst eine IP-Adresse benötigt. Gleichzeitig zum Gate können die Tablets gestartet werden, da diese auch eine Weile zum Booten benötigen und bis dahin das Gate hochgefahren ist.
    • SIZ/TouchScores: diese können parallel zu den Switches gestartet werden, sie brauchen lange genug zum Booten, dass sie noch eine IP-Adresse bekommen
    • OpticScorServer: Notwendig, wenn die Ergebnisse der Endgeräte irgendwo in einen Wettkampf gespeichert, oder die Stände visualisiert werden sollen.


    Kurz:

    • Liegt der Router auf Dauerstrom und der Rest wird am Schießtag eingeschalten, sollte es keine Probleme geben.
    • Das WLAN für den Schießstand ist ausschließlich für die Endgeräte des Schießstandes zu verwenden. Privat-Handys etc. haben darin nichts verloren.
    • Bis auf die Tablets sollte grundsätzlich alles per Netzwerkkabel verbunden sein. Damit fährt man einfach am sichersten.


    Kann das irgendwas mit der Einschaltreihenfolge zu tun haben? Es könnte sein, dass der Switch noch stromlos war, als die SIZs hochgefahren wurden, aber versucht das SIZ dann nicht später erneut, den Messrahmen zu finden?

    Tut es schon, nur wenn der Messrahmen und/oder das SIZ keine IP-Adresse beziehen konnten, weil der Switch aus war, dann sind diese Geräte nicht im Netzwerk verfügbar. Die Geräte können nicht unbegrenzt lange auf eine IP-Adresse warten und booten irgendwann ohne Netzwerk-Verbindung (der Messrahmen kann ja z. B. auch per RS232 angeschlossen sein).

  • bei uns startet - ausser dem server-rechner - alles gleichzeitig (ein "hauptschalter"),--> keine probleme.

    Der router ist gott sei dank schneller up als die messrahmen oder touch-SIZ

    mfsg daniel

  • Hallo, Danke für die vielen Antworten.


    Ich tippe (hoffe) auch einfach auf eine Einschaltreihenfolge-Problematik.


    Wie gesagt hatten ja alle Messrahmen und SIZ die ihnen zugewiesene IP und reagierten auch auf Pings vom Server aus - trotzdem wurden Schüssen nicht erkannt, auch Neustart des Servers brachte nichts. Aber wie gesagt mag das tatsächlich einfach an der Einschaltreihenfolge gelegen haben.


    Was allerdings auch aufgefallen ist: wir fahren die miniPCs immer vom Server aus herunter. Hin und wieder fährt einer der miniPCs danach aber nicht mehr vollständig hoch und bleibt im Linux-Bootvorgang (i.e. mit Textausgabe) hängen. Strom trennen und wieder verbinden hilft bislang, macht uns aber natürlich ein wenig Sorgen...

  • Hallo,

    wir haben nun seit letzer Woche unsere Disag Anlage in Betrieb.

    Ich würde mir gerne den Teiler anzeigen lassen beim Training. Links im Menü kann ich es nirgens aktivieren. Wo genau kann man es einstellen? Gibts dafür eine Anleitung?


    Lg

    Walther LG 400 Alutec Expert Electronic - seit 02/2016

  • Grüß dich,

    da ich keine Gate-Anlage habe kann ich nur aus der Theorie Sprechen:


    In der OSS - ServerSoftware am PC gibt es folgende Option:

    Extras>Gate> Setup> --> Reiter Konfiguraton "Teiler"


    dann müssten am linken Rand mehr Buttons erscheinen - eben auc hder Teiler, was du willst.


    mfsg daniel

  • Abend zusammen,

    ich hab mal ein paar fragen..

    Wir haben die Disag Anlage mit den 14 Zoll Tablets.


    Kam das bei euch auch schon öfters vor, dass während dem Schießen sozusagen das Fenster neue geladen wird und kurzzeitig das Disag Logo erscheint? Danach geht es normal weiter.



    Und ist das normal, dass die Rahmen kurz nach Schussabgabe kurz piepen?

    Walther LG 400 Alutec Expert Electronic - seit 02/2016

  • Hallo Oli,


    habt ihr die Messrahmen mit Wechsel?

    Hier kann sein, dass du nach dem Schuss kurz die "Ausrichtung" des Wechslerarms hörst.

    Das ist aber normal.


    Grüße

  • Ja genau wir haben die wechsler 😀


    Und was hat das mit dem neu Laden auf sich?


    Lg

    Walther LG 400 Alutec Expert Electronic - seit 02/2016